Sustituir la versión de jQuery en WordPress

Hace poco trabajando en un proyecto de Wordpress con el theme Minimal Lite, me dió este error:

Error: Bootstrap’s JavaScript requires jQuery version 1.9.1 or higher but less than v3.0.0.

Sustituir la versión de jQuery en WordPress fue la manera de solucionarlo.

 

Error: Bootstrap’s JavaScript requires jQuery version 1.9.1 or higher but less than v3.0.0

Vamos a analizar el error, lo que me esta diciendo es que la plantilla o theme que estoy  usando solo soporta versiones de jQuery mayores que la 1.9.1 y menores que la 3.0.0

 

Saber que versión de jQuery está en uso

Si queremos saber la versión de jQuery que estamos usando, una opción es ver el código fuente del fichero /wp-includes/js/jquery/jquery.min.js

 

Sustituir la versión de jQuery en WordPress

Añadiendo la siguiente función en el fichero functions.php de nuestro theme, sustituimos la versión de jQuery local por la del CDN de Google

 

 

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *